I was trying to compile XBMC from the subversion repository and was receiving an error when it got to the Goom visualization. Unfortunately, the exact error is beyond my terminal history but can be found in a thread on the XBMC forums (http://blog.xbmc.org/forum/showthread.php?t=45463&page=2). In that thread there is this dirty work-around:

sed -i xbmc/visualizations/Goom/goom2k4-0/src/goomsl_yacc.y -e 's/case FLOAT_TK/case 264/'
sed -i xbmc/visualizations/Goom/goom2k4-0/src/goomsl_yacc.y -e 's/case INT_TK/case 263/'
sed -i xbmc/visualizations/Goom/goom2k4-0/src/goomsl_yacc.y -e 's/case PTR_TK/case 262/'

It worked for me. An additional note of interest when compiling XBMC is if you want to install to a non-standard location,

./configure --prefix=/path/to/destination

DOES NOT WORK. You have to use :

make install PREFIX=/path/to/destination

So, I accidentally installed it on top of the version I received via apt-get from the xbmc ppa. Shouldn’t be an issue.